この記事は1年以上前の記事です。情報が古い場合がありますのでお気を付け下さい。

SnapCrab_NoName_2015-9-10_16-50-49_No-00

SSL サーバーが古い可能性があります。

ERR_SSL_FALLBACK_BEYOND_MINIMUM_VERSION

サーバーに安全に接続できません。このウェブサイトは以前は利用できていた可能性がありますが、サーバーに問題があります。こうしたサイトに接続すると、すべてのユーザーにセキュリティ上の問題が生じるため、接続は無効になりました。

こんなのが出てきて見ることができません。(これ

Chrome://flagsをいじれば回避できるのではと思って確認してみてもそのような項目はどこにもありませんでした。

つい最近のchromeアップデートから古いSSLサーバーを使ってるサイトを弾くようになりました。
これは、スマートフォン版でも同じで、Chromeの最新版を使ってる場合はこのように表示できなくなります。

なので、とりあえずは別のブラウザを使うしか無いと思われます。
SnapCrab_NoName_2015-9-10_16-46-58_No-00